Cómo resolver el error de ubuntu cli "exec:" less": el archivo ejecutable no se encuentra en $PATH"

Durante la ejecución de algunos comandos con herramientas como los binarios de Plesk, se enfrentará a una excepción sobre un ejecutable faltante que no se ha encontrado en $PATH. Esto sucede comúnmente con la utilidad less (no el preprocesador CSS sino la herramienta Unix Less).

Less es una utilidad para mostrar texto sin formato en la pantalla del terminal. Es capaz de mostrar un archivo línea por línea, aunque no es posible manipular o editar el texto. Además, sus comandos se basan en el conocido editor "vi", que se diferencia en que no tiene que leer todo el contenido del archivo antes de abrirlo (rendimiento en su máxima expresión).

Si se enfrenta a esta excepción al ejecutar algún comando que mostrará algún texto en la terminal, el problema es que no tiene la utilidad less instalada en su sistema. Esto sucede generalmente en sistemas operativos basados ​​en Debian y especialmente en distribuciones de Ubuntu que están montadas en servidores AWS.

Solución

Instala la utilidad less con el siguiente comando en sistemas basados ​​en Debian:

sudo apt-get install less

Que te diviertas ❤️!

Esto podria interesarte

Conviertete en un programador más sociable